No voice transmission when using the softphone function with Alcatel OmniPCX Office
Update status | April 2023 |
---|---|
Relevance | ProCall 8 Enterprise ProCall 7 Enterprise |
Observation
If a softphone call is in progress, the voice transmission stops after 15 minutes.
However, ProCall Enterprise still shows the call as active.
Possible cause
This circumstance may be related to the PBX configuration. This can be verified by analyzing a PCAP recording.
Until the session refresh, the PBX or gateway sends the RTP stream from the source address specified in the SDP (here, for example, c=IN IP4 192.168.111.60 and m=audio 32020 RTP/AVP 8 96):
Internet Protocol Version 4, Src: AL OXE (192.168.111.60), Dst: PCE-Server (192.168.111.39)
User Datagram Protocol, Src Port: 5059, Dst Port: 56539
Session Initiation Protocol (183)
Status-Line: SIP/2.0 183 Session Progress
Message Header
Message Body
Session Description Protocol
Session Description Protocol Version (v): 0
Owner/Creator, Session Id (o): default 1676024315 1676024315 IN IP4 192.168.111.60
Session Name (s): UC Media Server
Connection Information (c): IN IP4 192.168.111.60
Time Description, active time (t): 0 0
Media Description, name and address (m): audio 32020 RTP/AVP 8 96
Media Attribute (a): rtpmap:8 PCMA/8000
Media Attribute (a): rtcp:32021
Media Attribute (a): rtpmap:96 telephone-event/8000
Media Attribute (a): fmtp:96 0-15
Media Attribute (a): silenceSupp:off - - - -
Media Attribute (a): sendrecv
Media Attribute (a): ptime:30
Media Attribute (a): maxptime:90
After half the time of the session expires (here in the example 1800 seconds due to session expires: 1800;refresher=uac) the session refresh is initiated and the PBX sends new connection data in the SDP (here for example c=IN IP4 192.168.111.60 and m=audio 32022 RTP/AVP 8 96), the PBX informs about the change of the UDP port from 32020 to 32022:
Session Description Protocol
Session Description Protocol Version (v): 0
Owner/Creator, Session Id (o): default 1676024315 1676024316 IN IP4 192.168.111.60
Session Name (s): UC Media Server
Connection Information (c): IN IP4 192.168.111.60
Time Description, active time (t): 0 0
Media Description, name and address (m): audio 32022 RTP/AVP 8 96
Media Attribute (a): rtpmap:8 PCMA/8000
Media Attribute (a): rtcp:32023
Media Attribute (a): rtpmap:96 telephone-event/8000
Media Attribute (a): fmtp:96 0-15
Media Attribute (a): silenceSupp:off - - - -
Media Attribute (a): sendrecv
Media Attribute (a): ptime:30
Media Attribute (a): maxptime:90
As already shown in the above illustration of the PCAP recording, the source of the media stream from the PBX gateway does not change, but only the estos UC media server takes into account the new connection data communicated by the PBX:
The estos UC media server continues to receive the RTP data stream from the PBX after the session refresh, but discards it because according to the PBX SDP it should now come from a different source port.
Solution
In the Alcatel OmniPCX Office under Voice Parameters/SIP trunk lines, there is the menu item RTP Proxy: Fixed Ports.
This item must be set so that the telephone system always uses the same port.