Meldung "Es ist kein standardmäßiger E-Mail-Client vorhanden" bei Update von Microsoft Office 365 (24. April 2020)
September 2020
Beobachtung
Seit dem oben genannten Update von Microsoft Office 365 kann der ProCall Client für Windows MAPI nicht mehr initialisieren.
Folgendes Hinweisfenster beim Start des ProCall Clients kann ein Anzeichen dafür sein:
Beispiel Screenshot: Hinweis Microsoft Office Outlook
Das Hinweisfenster kann auch erscheinen, wenn andere Ursachen als das hier beschriebene Problem zugrunde liegen.
Problem nachvollziehen
Mit dem Testtool MFCMapi kann das Problem nachvollzogen werden.
MFCMapi ist ein Test-Tool zum Überprüfen der MAPI Schnittstelle und zur Lokalisierung evtl. MAPI Fehler.
Das Tool ist unter https://github.com/stephenegriffin/mfcmapi zu finden.
Mögliche Ursache
Update auf Microsoft Office Version vom 24. April 2020 löst dieses Verhalten aus.
Workaround
Zu dem beobachteten Verhalten haben wir folgende Workarounds erarbeitet:
- Anbindung an Microsoft Outlook für den ProCall Client für Windows ändern
MAPI deaktivieren und Verbindung über EWS herstellen - Umgebungsvariablen des betroffenen Client Systems anpassen
https://stackoverflow.com/questions/61469343/mapiinitialize-fails-after-april-24-2020-update-of-office-365 - Zurücksetzen auf eine frühere Microsoft Office Version (vor 24. April 2020)
https://support.microsoft.com/en-us/help/2770432/how-to-revert-to-an-earlier-version-of-office-2013-or-office-2016-clic
Lösung
Keine bekannte. Eine Lösung kann nicht über ProCall Enterprise herbeigeführt werden.
Es muss ein Fix von Microsoft bereitgestellt werden.